search
menu
person

Как в Excel найти значения из одного столбца в другом столбце

10.09.2019, 12:53

В сегодняшнем выпуске рассмотрим популярный вопрос Как в Excel найти значения из одного столбца в другом столбце.

Данный вопрос очень часто появляется и в жизни бывают много задач, которые требуют например сравнить списки, большие списки с ФИО.

Но мы же не будем каждое значение одного столбца вручную сравнивать со значениями второго столбца.

Поэтому применим функции Excel.

И так, у нас есть два столбца со значениями:

500429     500429
НЗР000000001204   -1187234937
2,147E+09     1577329455
-1,106E+09     -1602497801
500915     -169464495
2,147E+09     1819498112
2,147E+09     -1861647569
НЗР000000003690   НЗР000000001204
      -2100089984
      2147238856
      2147238865
      2147249303
      2147242885
      2147249303
      2147253748
      2147257732
      2147263841
      2147264655
      2147265218
      500429

 

Нам необходимо узнать, содержатся ли значения первого столбца во втором.

Решение достаточно простое, сама формула будет иметь вид 

=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A56;$C$56:$C$75;0));"Нету";"Есть")

Рассмотрим более подробно.

Вначале мы используем функцию ПОИСКПОЗ - данная функция выполняет поиск указанного элемента в массиве ячеек и возвращает его позицию.

Синтаксит

ПОИСКПОЗ(значение которое ищем;массив в котором осуществляем поиск;[тип_сопоставления])

С помощью ПОИСКПОЗ(A56;$C$56:$C$75;0) определяем позицию (да в принципе этой формулы уже достаточно, чтобы определить наличие значений первого столбца во втором, только эта формула будет выводить номер позиции, в которой находится искомое значение), но мы хотим видеть конкретное значение есть/нету.

Далее используем функцию ЕОШИБКА она проверяет значение ячейки и если в ней будет #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! то мы получим ИСТИНА, а если в ячейки какое-то конкретное значение то ЛОЖЬ.

Теперь будем использовать функцию ЕСЛИ, ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(A56;$C$56:$C$75;0));"Нету";"Есть")

то есть мы здесь проверяем, если ошибка то нету иначе есть.

Таким образом мы смогли проверить наличие значений первого столбца во втором.

Категория: Интересные решения | Добавил: (10.09.2019) Просмотров: 1 | Теги: если, ПОИСКПОЗ, ЕОШИБКА | Рейтинг: 0.0/0

Всего комментариев: 0
avatar