menu
person

Задача №2860

На­пи­ши­те в от­ве­те число раз­лич­ных зна­че­ний вход­ной пе­ре­мен

Поиск задачи:

На­пи­ши­те в от­ве­те число раз­лич­ных зна­че­ний вход­ной пе­ре­мен­ной k, при ко­то­рых про­грам­ма выдаёт тот же ответ, что и при вход­ном зна­че­нии k = 36. Зна­че­ние k = 36 также вклю­ча­ет­ся в подсчёт раз­лич­ных зна­че­ний k. Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

 

 

Бей­сик Python
DIM K, I AS LONG
 INPUT K
 I = 0
 WHILE F(I) < K
    I = I + 1
 WEND
 PRINT I
 FUNCTION F(N)
    F = N*(N-1)+10
 END FUNCTION

def f(n):

    return n*(n-1)+10

k = int(input())

i = 0

while f(i) < k:

    i = i + 1

print(i)

 

 

Пас­каль Ал­го­рит­ми­че­ский язык
var k, i : longint;
    function f(n: longint) : longint;
        begin
            f := n*(n-1)+10
        end;
begin
    readln(k);
    i := 0;
    while (f(i) < k) do
        i := i+1;
    writeln(i)
end.
алг
нач
цел i, k
ввод k
i := 0
нц пока f(i) < k
i := i+1
кц
вывод i
кон
алг цел f(цел n)
нач
знач := n*(n-1)+10
кон
Си
#include <stdio.h>
long f(long n) 
{
    return n*(n-1)+10;
}
void main()
{
    long k, i;
    scanf("%ld", &k);
    i = 0;
    while (f(i) < k)
        i++;
    printf("%ld", i);
}

 

 

Категория: по информатике | Добавил: Просмотров: 1 | Теги: Ана­лиз программы с цик­ла­ми | Рейтинг: 0.0/0
Всего комментариев: 0