menu
person

Задача №2786

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния

Поиск задачи:

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы, за­пи­сан­ной ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния.

 

 

 

Бей­сик Python
DIM N, S AS INTEGER
 N = 1
 S = 0
 WHILE N <= 100
S = S + 30
N = N * 2
 WEND
 PRINT S

n = 1

s = 0

while n <= 100:

    s = s + 30

    n = n * 2

print(s)

 

 

Пас­каль Ал­го­рит­ми­че­ский язык
var n, s: integer;
begin
    n := 1;
    s := 0;
    while n <= 100 do
    begin
        s := s + 30;
        n := n * 2
    end;
    write(s)
end.

 

алг
нач
цел n, s
n := 1
s := 0
нц пока n <= 100
    s := s + 30
    n := n * 2
кц
вывод s
кон
Си
#include <stdio.h>
void main()
{
    int n, s;
    n = 1;
    s = 0;
    while (n <= 100)
    {
        s = s + 30;
        n = n * 2;
    }
    printf("%d", s);
}

 

 

По­яс­не­ние.

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие n ≤ 100, т. е. пе­ре­мен­ная n опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл. По­сколь­ку из­на­чаль­но n = 1, цикл вы­пол­нит­ся 7 раз, сле­до­ва­тель­но, s = 30 · 7 = 210.

 

Ответ: 210.

Категория: по информатике | Добавил: Просмотров: 1 | Теги: Ана­лиз программ | Рейтинг: 0.0/0
Всего комментариев: 0