menu
person

Задача №2789

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния

Поиск задачи:

Опре­де­ли­те, что будет на­пе­ча­та­но в ре­зуль­та­те вы­пол­не­ния про­грам­мы (за­пи­сан­ной ниже на раз­ных язы­ках про­грам­ми­ро­ва­ния).

 

 

Бей­сик Пас­каль
DIM N, S AS INTEGER
 N = 1
 S = 0
 WHILE S <= 1024
S = S + 128
N = N * 2
 WEND
 PRINT N
program B05;
var n, s: integer;
begin
    n := 1;
    s := 0;
    while s <= 1024 do
    begin
        s := s + 128;
        n := n * 2;
    end;
    write(n)
end.

 

Си Ал­го­рит­ми­че­ский язык
#include <stdio.h>
void main()
{
    int n, s;
    n = 1;
    s = 0;
    while (s <= 1024)
    {
        s = s + 128;
        n = n * 2;
    }
    printf("%d", n);
}
алг
нач
цел n, s
n := 1
s := 0
нц пока s <= 1024
    s := s + 128
    n := n * 2
кц
вывод n
кон

 

 

По­яс­не­ние.

Цикл while вы­пол­ня­ет­ся до тех пор, пока ис­тин­но усло­вие s ≤ 1024, т. е. пе­ре­мен­ная s опре­де­ля­ет, сколь­ко раз вы­пол­нит­ся цикл.

За­ме­тим, что 1024/128=8 После 9 шага s ста­нет рав­ной 1152 и усло­вие s ≤ 1024 ока­жет­ся не­вы­пол­нен­ным, цикл пре­рвет­ся. Сле­до­ва­тель­но, зна­че­ние n будет равно 29 = 512.

 

Ответ: 512.

Категория: по информатике | Добавил: Просмотров: 1 | Теги: Ана­лиз программ | Рейтинг: 0.0/0
Всего комментариев: 0