menu
person

Задача №2859

При каком наи­боль­шем зна­че­нии вход­ной пе­ре­мен­ной k про­грам­ма

Поиск задачи:

При каком наи­боль­шем зна­че­нии вход­ной пе­ре­мен­ной k про­грам­ма выдаёт тот же ответ, что и при вход­ном зна­че­нии k = 64? Для Ва­ше­го удоб­ства про­грам­ма при­ве­де­на на пяти язы­ках про­грам­ми­ро­ва­ния.

 

Бей­сик Python

 

DIM K, I AS LONG
 INPUT K
 I = 12
 WHILE I > 0 AND F(I) >= K
    I = I - 1
 WEND
 PRINT I
 
 FUNCTION F(N)
    F = N * N - 20
 END FUNCTION

 

def f(n):

    return n * n - 20

 

k = int(input())

i = 12

while i > 0 and f(i) >= k:

    i = i - 1

print(i)

 

 

Ал­го­рит­ми­че­ский язык Пас­каль

 

алг
нач
    цел i, k
    ввод k
    i := 12
    нц пока i > 0 и f(i) >= k
        i := i - 1
    кц
    вывод i
кон
 
алг цел f(цел n)
нач
    знач := n * n - 20
кон

 

var k, i : longint;
function f(n: longint) : longint;
begin
    f := n * n - 20
end;
begin
    readln(k);
    i := 12;
    while (i>0) and (f(i) >= k) do
        i := i-1;
    writeln(i)
end.

 

Си
#include <stdio.h>
long f(long n) { return n * n - 20; }
int main()
{ 
    long k, i;
    scanf("%ld", &k);
    i = 12;
    while (i > 0 && f(i) >= k) i––;
    printf("%ld", i);
    return 0;
}

 

 

 

Категория: по информатике | Добавил: Просмотров: 1 | Теги: Ана­лиз программы с цик­ла­ми | Рейтинг: 0.0/0
Всего комментариев: 0